Discussion:
Bug#988338: unblock: pkg-js-tools/0.9.65
(too old to reply)
Yadd
2021-05-10 19:10:02 UTC
Permalink
Package: release.debian.org
Severity: normal
User: ***@packages.debian.org
Usertags: unblock

Please unblock package pkg-js-tools

[ Reason ]
pkg-js-tools provides dh-sequence-nodejs. It simulates npm install
features to install node modules in the right places.
Since 0.9.52, it reads .npmignore to not install some files. But I
missed to force package.json install, this is fixed by this version
(0.9.65). This unblock is required to fix node-got RC bug (#988334)

[ Impact ]
If not unblocked, node-got and maybe some other node packages may be
broken

[ Tests ]
No specific test

[ Risks ]
This patch includes:
* some doc fixes
* GitHub tags update
* package.json install even if removed by .npmignore

[ Checklist ]
[X] all changes are documented in the d/changelog
[X] I reviewed all changes and I approve them
[X] attach debdiff against the package in testing

Cheers,
Yadd (from hospital)

unblock pkg-js-tools/0.9.65
Debian Bug Tracking System
2021-05-10 20:10:01 UTC
Permalink
Your message dated Mon, 10 May 2021 20:04:33 +0000
with message-id <E1lgC8n-0000pV-***@respighi.debian.org>
and subject line unblock pkg-js-tools
has caused the Debian Bug report #988338,
regarding unblock: pkg-js-tools/0.9.65
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ***@bugs.debian.org
immediately.)
--
988338: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=988338
Debian Bug Tracking System
Contact ***@bugs.debian.org with problems
Loading...